Rabu, 17 Februari 2010

Catatan Saya

----------------------
Catatan Router Pertama
----------------------
Cisco Router Configuration Tutorial :

Getting started with Cisco :
Router>
2.1 Modes :
Router>?
2.2 Unprivileged and privileged modes :
Router>show ?
Router>
to
Router#

3. Configuring your Cisco Router :

Router#show interfaces
Router#show ip protocols
Router#show ip route
Router#show ip arp

3.1 Global configuration (config) :

Router#config terminal
Router(config)#
Router(config)#hostname ExampleName
ExampleName(config)#

Another useful command issued from config
mode is the command to designate the DNS server to be used by the router:

ExampleName(config)#ip name-server aa.bb.cc.dd
ExampleName(config)#ctrl-Z
ExampleName#

This is also where you set the password for privileged mode :

ExampleName(config)#enable secret examplepassword
ExampleName(config)#ctrl-Z
ExampleName#

3.2 Configuring Cisco router interfaces
Cisco interface naming is straightforward.Individual interfaces are referred to by this convention:

media type slot#/port#
ExampleName#show interface ethernet 6/2
If your router does not have slots, like a 1600, then the interface name consists only of:

media type port#
For example:

ExampleName#show interface serial 0
Here is an example of configuring a serial port with an IP address:

ExampleName#config
ExampleName(config)#interface serial 1/1
ExampleName(config-if)#ip address 192.168.155.2 255.255.255.0
ExampleName(config-if)#no shutdown
ExampleName(config-if)#ctrl-Z
ExampleName#
ExampleName#show interface serial 1/1

ExampleName(config)#interface serial 1/1
ExampleName(config-if)#shutdown
ExampleName(config-if)#ctrl-Z
ExampleName#show interface serial 1/1
ExampleName(config)#interface serail 1/1
ExampleName(config-if)#no ip address 192.168.155.2 255.255.255.0
ExampleName(config-if)ctrl-Z
ExampleName#show interface serial 1/1

3.3 Configuring Cisco Routing

ExampleName(config)#ip routing
ExampleName(config)#ctrl-Z

There are two main ways a router knows where to send packets. The administrator can assign static routes, or the router can learn routes by employing a dynamic routing protocol :

ExampleName#config
ExampleName(config)#ip route 172.16.0.0 255.255.255.0 192.168.150.1
ExampleName(config)#ctrl-Z
ExampleName#show ip route

This document describes how to configure the Routing Information Protocol (RIP)on Cisco routers. From the command-line, we must explicitly tell the router which protocol to use, and what networks the protocol will route for:

ExampleName#config

ExampleName(config)#router rip
ExampleName(config-router)#network aa.bb.cc.dd
ExampleName(config-router)#network ee.ff.gg.hh
ExampleName(config-router)#ctrl-Z
ExampleName#show ip protocols

3.4 Saving your Cisco Router configuration :

ExampleName#show running-config
ExampleName#show startup-config

3.5 Example Cisco Router configuration :

Router>enable

Router#config
Router(config)#hostname Pelatihan
Pelatihan(config)#interface serial 1/1
Pelatihan(config-if)ip address 192.168.155.2 255.255.255.0
Pelatihan(config-if)no shutdown
Pelatihan(config-if)ctrl-z
Pelatihan#show interface serial 1/1
Pelatihan#config
Pelatihan(config)#interface ethernet 2/3
Pelatihan(config-if)#ip address 192.168.150.90 255.255.255.0
Pelatihan(config-if)#no shutdown
Pelatihan(config-if)#ctrl-z
Pelatihan#show interface ethernet 2/3
Pelatihan#config
Pelatihan(config)#router rip
Pelatihan(config-router)#network 192.168.155.0
Pelatihan(config-router)#network 192.168.150.0
Pelatihan(config-router)#ctrl-z
Pelatihan#show ip protocols
Pelatihan#ping 192.168.150.1
Pelatihan#config
Pelatihan(config)#ip name-server 172.16.0.10
Pelatihan(config)#ctrl-z
Pelatihan#ping archie.au
Pelatihan#config
Pelatihan(config)#enable secret password
Pelatihan(config)#ctrl-z
Pelatihan#copy running-config startup-config
Pelatihan#exit

4. Troubleshooting your Cisco router :

ExampleName#show interfaces
ExampleName#show ip protocols
ExampleName#show ip route
ExampleName#show ip arp

4.1 Testing connectivity :

IP Message Control Protocol (ICMP)

ExampleName#ping xx.xx.xx.xx
ExampleName#trace xx.xx.xx.xx

5. References
Leinwand, Pinsky and Culpepper Cisco Router Configuration. Indianapolis, Indiana: Cisco Press, 1998. Cisco Systems, Inc., http://www.cisco.com

%%%%%%%%%%%%
Catatan Router Kedua
%%%%%%%%%%%%

----------------------------------
cek Link kabel V35 DTE atau DCE
-----------------------------------

router>
router>enable
router#
router#show controller s0

maka, akan Tampil sebagai berikut :

interface Serial0
Hardware is PowerQUICC MPC860
DTE V.35 clocks stopped.
idb at 0x82048DEC, driver data structure at 0x8204B1B0
SCC Registers:
General [GSMR]=0x2:0x00000000, Protocol-specific [PSMR]=0x8
Events [SCCE]=0x0000, Mask [SCCM]=0x0000, Status [SCCS]=0x00
Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7
EInterrupt Registers:
Config [CICR]=0x00365F80, Pending [CIPR]=0x0000C006
Mask [CIMR]=0x00200000, In-srv [CISR]=0x00000000
Command register [CR]=0x5C0
Port A [PADIR]=0x1000, [PAPAR]=0x99C3
[PAODR]=0x0000, [PADAT]=0x66FF
Port B [PBDIR]=0x09C0F, [PBPAR]=0x0E00E
[PBODR]=0x00000, [PBDAT]=0x09D3C
Port C [PCDIR]=0x000, [PCPAR]=0x000
[PCSO]=0xC20, [PCDAT]=0x3CC, [PCINT]=0x000
Receive Ring
rmd(FF003030): status 9000 length 60C address 3956524
rmd(FF003038): status B000 length 60C address 3955EA4
Transmit Ring
tmd(FF0030B0): status DC00 length 12 address 3A6A174
--More--

untuk stopnya tekan tombol Ctrl dan tombol c, akan tampil prompt :

router#
router#
--------------------------------------------------------------------
konfirasi ip ke interface serial 0 , Contoh : network 192.168.1.4/30
--------------------------------------------------------------------
router#
router#config terminal
router(config)#int s0
router(config-if)#ip address 192.168.1.5 255.255.255.252
router(config-if)#no shut
router(config-if)#(Ctrl + Z)
router#
----------------------
Melihat Interface s0 :
----------------------
router#
router#show int s0
maka, akan tampil sebagai berikut :
Serial0 is administratively down, line protocol is down
Hardware is PowerQUICC Serial
Internet address is 192.168.1.14/27
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
Keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:59:15
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
7 packets output, 984 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=down RTS=down CTS=up

router#

----------------------------------------
melihat configurasi yang telah di buat :
----------------------------------------

router#
router#show run

maka, akan tampil sebagai berikut :

Current configuration : 687 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router_pekayon
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero

--More--

ip cef
!
!
no ip dhcp use vrf connected
!
!
!
!
!
!
interface FastEthernet0
no ip address
shutdown
speed auto
!
interface Serial0
ip address 192.168.1.14 255.255.255.224
shutdown
no fair-queue
!
interface Serial1
ip address 192.168.1.25 255.255.255.224
shutdown

--More--

interface Serial0
ip address 192.168.1.14 255.255.255.224
shutdown
!
ip classless
!
no ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
end

router#

Tidak ada komentar: